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PERTEMUAN 7 

Tahap Pembuatan Website Dan Program 
 

 

 

 

 

 

 

 

TAHAP PEMBUATAN WEB DAN PROGRAMNYA 

 
Tahap 1. Perencanaan, Perancangan dan Tujuan 
Merupakan tahap awal dalam membangun/membuat situs yang professional, seperti membuat 
scenario perencanaan, perancangan, diagram alur, tujuan dan mempersiapkan materi atau isi 
dari situs. 
 
Tahap 2. Memilih dan mempersiapkan Tool 
Merupakan cara memilih tool-tool yang tepat untuk membangun situs, karena dengan 
menggunakan tool yang tepat akan mempercepat dan mempermudah kita dalam membangun 
sebuah situs dan dilanjutkan dengan cara menginstalasikan tool-tool tersebut. 
 
Tahap 3. Mendesain Web 
Merupakan tahap pembuatan grafik-grafik web untuk melengkapi desain cantik sebuah situs, 
seperti header, tombol, navigasi, logo, motto, foto, label dan lain-lain. 
 
Tahap 4. Mempersiapkan Database Server 
Merupakan tahap mempersiapkan dan membuat data dalam database yang terdiri dari tabel-
tabel, nanti database ini akan berfungsi sebagai tempat penyimpanan data. 
 
Tahap 5. Pemrograman Web 
Merupakan tahap pembuatan skrip-skrip di server yang akan menangani berbagai aktivitas di 
sebuah situs, seperti bagian sysadmin, user, manajemen kategori, manajemen berita, 
manajemen anggota, pencarian berita, counter dll. 
 
Tahap 6. Menggabungkan Desain dan Pemrograman Web 
Merupakan tahap atau cara untuk menggabungkan antara desain dan pemrograman yang telah 
dibuat pada tahap sebelumnya menjadi satu kesatuan utuh, seperti membuat layout, 
mengorganisasikan file-file web, mengatur posisi desain header, memasang grafik-grafik web 
pada suatu halaman, memasang script-script pemrograman dll. 
 
 
 
 
 

� Perencanaan, Perancangan dan Tujuan 
� Memilih dan Mempersiapkan Tool 
� Mendesain Web 
� Mempersiapkan Database Server 
� Pemrograman Web 
� Menggabungkan Desain dan Pemrograman Web 
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Tahap 1. Perencanaan, Perancangan dan Tujuan 
 
Identifikasi awal yang perlu diperhatikan sebelum membangun situs, adalah : 
1. Situs apa yang dibuat ? 
2. Siapa pengunjung yang anda harapkan berkunjung ke situs ? 
3. Apa saja aktivitas yang dapat mereka lakukan dalam situs ? 
4. Apa target  yang ingin dicapai dari pembuatan situs tersebut ? 

 

• Berkenaan dengan proyek situs yang akan dibuat nantinya, yaitu situs berita, maka kita 
akan menjawabnya sebagai berikut : 

 
• Situs yang akan dibuat adalah situs berita, lebih spesifiknya adalah situs berita mengenai 
film-film/CD/VCD/DVD yang meliputi judul film baru, Panduan membeli film/CD/VCD/DVD 
dll. 

 
• Pengunjungnya adalah pemilik toko Film/CD/VCD/DVD, pramuniaga, Sutradara, 
perusahaan-perusahaan dan orang awam yang akan membeli Film/CD/VCD/DVD. 

 

• Aktivitas yang akan dijumpai didalam situs tersebut adalah pengunjung dapat membaca 
artikel/tulisan seputar Film/CD/VCD/DVD baru berdasarkan kategori, artikel atau berita, 
mencari artikel atau berita mengenai judul Film/CD/VCD/DVD yang diinginkan. 

 

• Target yang ingin dicapai dari situs tersebut adalah pengunjung menjadi mengerti mengenai 
buku apa saja yang layak dibaca dan juga dapat menambah wawasan mereka. 

 
Kemudian langkah selanjutnya buatlah outline (garis besar) dari situs tersebut. Cara yang 

mudah adalah dibuat flowchart/diagram alir. Flowchart adalah gambaran yang menampilkan 
struktur, hirarki dan isi halaman per halaman, biasanya berbentuk pohon yang bercabang-
cabang fungsinya untuk mempermudah dalam mengatur kode dan HTMLnya, terutama link 
untuk navigasi penjelajahan ke seluruh halaman web. Adapun contoh flowchart dapat dilihat 
seperti berikut : 
 
 
 
 
  
 
 
 
 
 
 

Gambar Contoh Flowchart suatu Situs 
 
 
 

 
 

HOME

Profil Berita Partner Produk Service Hubungi
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Tahap 2. Memilih dan Mempersiapkan Tool 
 
Dalam proyek ini kita membutuhkan setikdaknya lima tool, yaitu : 
 
1. Adobe photoshop merupakan salah satu software terbaik dalam menangani bidang 
desain, baik desain grafik, manipulasi foto maupun desain web. 

 
2. Macromedia dreamwever merupakan software yang sangat bagus dalam menangani 
tata letak (layout) halaman web 

 
3. Apache/Xampp/Wamp/AppServ adalah web server karena situs yang dibuat nantinya 
melibatkan pengolahan data di server, maka di komputer kita harus ada web servernya. 
Dengan adanya web server, kita bisa mensimulasikan situs yang kita buat di komputer 
lokal sebelum melakukan upload ke internet. 

 
4. PHP merupakan script yang akan mengolah dan memproses data secara interaktif dan 
dinamis. Script ini nantinya akan berjalan di sisi server untuk melakukan pemrosesan 
datanya. 

 
5. MySQL merupakan database server, semua data yang kita miliki akan disimpan ke dalam 
suatu tempat di server yang di tempatkan di dalam database server, nantinya PHP dapat 
mengolah data tersebut lebih lanjut. 

 
 
Tahap 3. Mendesain Web 
 
Dalam mendesain web proyek ini digunakan software Adobe Photoshop (Silahkan gunakan versi 
7, Versi 9/CS atau CS2 atau CS3). Kebetulan pada contoh ini digunakan Adobe Photoshop CS 
(Versi 9) 
 
Mempersiapkan Area Header Web 
 
Area header adalah area bagian paling atas dari suatu halaman web, pada area ini biasanya 
terdapat logo perusahaan, motto, foto mengenai situs yang akan dibuat dan navigasi. Berikut 
contoh membuat area header : 
 
 
 
 
 
 
 
Sebelum mulai mendesain header, pertama-tama kita harus mempersiapkan area untuk header, 
terutama ukuran dari header tersebut, baik tinggi maupun lebarnya. Caranya klik menu File > 

New, isikan Width : 775 Pixels, Height : 140 Pixels dan pilih Background Contents : White. Lihat 
gambar berikut :  
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Background Header 
 
Background adalah sebutan untuk latar belakang suatu desain. Background untuk header yang 
akan kita buat adalah background gradasi, yaitu background yang terdiri dari campuran 
beberapa warna. 

 
1. Klik Menu Layer > New >  Layer atau klik tombol Create a new layer pada palet layer 
untuk membuat layer baru (Layer1) diatas layer Background. Lihat gambar berikut : 

 
 
  
 
 
 
 
 
 
 

Atau 
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2. Klik tool Rectangular Marquee untuk membuat seleksi berbentuk kotak seperti berikut : 

 
 
 
 
 
 
 
 
3. Klik tool Gradient, lalu klik tombol Linear Gradient di option-barnya, kemudian klik 

Set foreground color dan atur warnanya : 364F63, lalu klik set background color dan 
atur warnanya : 7A95A6. Lihat gambar : 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
4. Klik dan seret dari atas ke bawah mengikuti tanda panah. Lihat Gambar : 

 
 
 
 

 
 
 

 

 

 

 

 

Foreground : 364F63 

Background : 7A95A6 
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5. Klik menu Select > Deselect untuk menghilangkan seleksi, lalu buat layer baru (Layer2). 
Kemudian, klik tool Rectangular Marquee dan buat seleksi kotak yang lebih kecil dari 
sebelumnya seperti gambar berikut : 

 
 
 
 
 
 
 
 
 
 
6. Klik tool Gradient, ubah warna Foreground : 888888 dan Background : DFDFDF 
(Lihat caranya di langkah 3), lalu klik dan seret dari atas ke bawah. Lihat gambar : 

 
 
 
 
 
 
 
7. Klik menu Select > Deselect, lalu buat layer baru. Klik tool Line, pada option barnya klik 
tombol Fill pixels, isikan Weight : 3 px dan atur Foreground : 000000, lalu gambarlah 
garis hitam di perbatasan kedua kotak. Lihat Gambar: 
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8. Buat layer baru, lalu gambarlah garis berwarna putih (FFFFFF) dengan Weight : 1 pxdan 
posisinya diatas garis berwarna hitam. Lihat gambar : 

 
 
 
 
 
 
 
 
 
 
Bentuk Navigasi 
 
Navigasi digunakan untuk menjelajah halaman demi halaman dalam suatu situs web. 
 
1. Buat layer baru (Layer 5), lalu klik tool Rectangular Marquee dan buat seleksi kotak 
seperti beikut : 

 
 
 
 
 
 

 
 
 
2. Klik tool Gradient, ubah warna Foreground : F2CB0E dan Background : EF9801, lalu 
klik dan seret dari atas ke bawah. Lihat gambar : 

 
 
 
 
 
 
 
 
 
3. Klik menu Select > Deselect, lalu klik tool Polygonal Lasso dan buatlah seleksi berbentuk 
segitiga di sisi kanan atas bentuk navigasi. Lihat gambar : 
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4. Tekan tombol Delete di keyboard untuk menghapus area yang terseleksi, kemudian klik 
menu Select > Deselect. Lihat gambar : 

 
 
 
 
 
 
 
 
 
5. Klik menu Edit > Stroke, isikan Width : 1 px, pilih color : FFFFFF dan location : Outside 
untuk memberikan garis pinggir berwarna putih pada bentuk navigasi. Lihat gambar : 
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Efek Gradasi Transparan pada Navigasi 
 
Selanjutnya kita akan memberikan efek gradasi transparan pada navigasi. 
 
1. Buat layer baru (Layer 6), klik tool Rectangular Marquee dan buat seleksi kotak seperti 
berikut : 

 
 
 
 
 
 
 
 
2. Klik tool Gradient, lalu ubah warna Foreground : FFFFFF, pada option barnya, klik 
tanda panah di sebelah kanan Gradient Picker, lalu pilih Foreground to 
Transparent. Lihat gambar : 
 

 
 
 
 
 
 

 
 
 
 
 
3. Klik dan seret dari atas ke bawah pada seleksi kotak. Lihat gambar : 

 
 
 
 
 
 
 
 
4. Klik menu Select > Deselect. Ulangi langkah 1 sampai 3 untuk membuat efek gradasi 
transparan putih pada bagian bawah navigasi. Lihat gambar berikut : 
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Tombol Navigasi  
 
Tombol diguakan sebagai link berbentuk grafik yang berfungsi mengantarkan pengunjung 
menjelajah halaman web dengan leluasa. 
 
1. Buat layer baru (layer 8). Klik tool Line, lalu gambarlah garis vertical berwarna hitam 
seperti berikut : 

 
 
 
 
 
 
 
 
2. Klik menu Layer > Duplicate Layer, lalu klik menu Image > Adjustments > Invert untuk 
mengubah garis hitam menjadi garis putih, kemudian klik tool Move, lalu tekan tombol 
panah ke kanan sekali pada keyboard. Lihat gambar: 

 
 
 
 
 
 

 
 
3. Klik menu Layer > Merge Down untuk menggabungkan dua layer (layer 8 dan layer 8 
copy) sehingga sekarang hanya ada layer 8 saja. Kemudian, klik menu Duplicate Layer, 
lalu pindahkan garis pembatas menggunakan tool Move. Lakukan hal yang sama untuk 
membuat garis pembatas berikutnya sampai sejumlah enam seperti gambar : 

 
 
 
 
 
 
 
 
 
4. Klik tool Text, pada option barnya, atur jenis huruf : Tahoma, Bold, ukuran : 11 pt dan 
warna : hitam. Kemudian, tulislah teks pada navigasi ‘Home’. Kemudian, klik tool Move 
untuk memindahkan teks Home pada posisinya. Dengan cara yang sama, tulislah teks 
‘Profil’ dan seterusnya seperti gambar : 
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Hiasan Foto  
 
Hiasan foto sangat berpengaruh menambah keindahan suatu desain. 
 
1. Klik menu File > Open, lalu buka file gambar dengan nama : Movie.jpg. Kemudian, Klik 
menu Image > Image Size, Height : 100 px, Klik tool Rectangular Marquee dan buat 
seleksi kotak seperti gambar berikut : 

 
 
 
 
 
 
 
 
 
 
2. Klik tool Gradient, lalu ubah warna foreground : 364F63, warna Background : 7A95A6 
pada option barnya, klik tanda panah disebelah kanan Gradient Picker, lalu pilih 
Foreground to Transparent. Klik dan seret dari kiri kekanan pada seleksi kotak. Lihat 
gambar:  

 
 
 
 
 
 
 
 
3. Klik menu Select > Deselect. Kemudian klik menu Select > All, lalu klik menu Edit > 
Copy. Lihat gambar : 
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4. Tutup gambar Movie dan simpan untuk kembali ke header, kemudian klik menu Edit > 
Paste, lalu letakkan gambar Movie di ujung kanan header. Klik Eraser Tool, hapus 
bagian kiri pada movie.jpg. Lihat gambar : 

 
 
 
 
 
 
 
 
5. Klik pada Layer 9 (gambar movie). Pada palet Layers, isikan bagian Opacity : 50 %, lalu 
klik tombol add layer mask. Lihat gambar : 

 
 
 
 
 
 
 
 
 
 
 

 
 
 
6. Klik tool Brush, lalu ubah warna Foreground : 000000, pada option barnya, klik tanda 
panah di sebelah kanan Brush Picker, lalu pilih Soft Round 100 pixels. Lihat gambar : 
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7. Klik pada sisi-sisi kiri dari gambar movie untuk menghaluskan gambar tersebut. Lihat 
gambar : 

 
 
 
 
 
 
 
 
 
Slogan Situs 
 
Slogan adalah kata-kata yang menjadi motto dari suatu perusahaan, produk, lembaga 
pendidikan atau organisasi lainnya. 
 
1. Klik tool Text, pada option barnya, atur jenis huruf : Arial, Bold, ukuran : 18 pt dan 
warna : putih. Kemudian, tulislah slogan diatas navigasi : ‘KIOS VIDEO EZZY’ dan 
dibawahnya slogan : ‘The Best CD/VCD/DVD’ dengan huruf : Arial, Italic, ukuran : 14 pt 
dan warna : putih. Lihat gambar : 

 
 
 
 

 
 
 
 
 
2. Klik pada layer text ‘Kios Video Ezzy ‘, Klik tool Move, lalu klik menu Layer > Layer Style 
> Outer Glow, maka akan tampil kotak dialognya, pilih Blend Mode : Lighten, Color : 
FF3F3F dan Size : 10. Lihat gambar : 
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Membuat Garis Bantu 
 
Garis bantu sangat berguna untuk mengatur ketepatan posisi suatu objek atau teks dalam 
suatu desain. Garis bantu yang akan kita buat, nantinya akan kita gunakan untuk membantu 
kita dalam melakukan pemotongan (slice) dan optimasi grafik. 
 
1. Klik menu View > Rulers untuk menampilkan mistar. Lihat gambar: 

 
   
 
 
 

 
 
 
 
 
 
2. Klik tool Move, lalu klik dan seret mistar horizontal untuk membuat garis bantu 
horizontal. Begitu juga caranya untuk membuat garis bantu vertikal. Lihat gambar : 

 
  
 
 
 
 
 
 
 
 
 
 
 

 
 
 

 

 

Mistar Horizontal 

Mistar  

Vertikal 

Garis bantu horizontal 

 

Garis bantu  

vertikal 
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3. Sekarang buatlah garis bantu seperti gambar berikut :   
 
 
 
 
 
 
 
 
 
Pemotongan Grafik Web 
 
Pemotongan (slice) grafik adalah suatu proses memotong suatu grafik menjadi bagian-bagian 
kecil. Slice merupakan suatu teknik yang sering digunakan oleh seorang web designer untuk 
mempercepat akses loading situs yang dibuat karena browser tidak membaca keseluruhan 
grafik terlebih dahulu lalu menampilkannya, tapi browser akan membaca potongan kecil grafik 
yang telah dibuat lalu langsung ditampilkan. 
 
1. Dari Photoshop klik menu File > Edit in ImageReady untuk membuka program Image 
Ready yang langsung menampilkan desain header yang telah kita buat. 

 
2. Klik tool Slice, lalu klik dan drag pada bagian kiri atas untuk membuat slice. Ikutilah 
garis Bantu yang telah kita buat. Slice yang terbentuk akan ditandai dengan label 01. 
Lihat gambar : 

 
 
 
 
 
 
 
 
 
 
 
 
 
3. Sekarang buatlah slice berikutnya, yaitu slice 02, caranya sama seperti langkah 2, 
kemudian buatlah slice sampai seperti gambar berikut : 
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Optimasi Grafik Web 
 
Optimasi grafik merupakan suatu proses mengoptimalkan grafik intinya memperkecil ukuran file 
dari grafik dengan menurunkan intensitas warna atau mengubah format pada grafik tersebut. 
 
1. Klik tab Optimized yang terletak dibagian atas dokumen, tab kedua dari kiri setelah tab 
original. Lihat gambar : 

 
 
 
 
 
 
 
 
 
 
2. Klik tool Slice Select Tool, lalu klik misalnya pada slice 01. Lihat gambar :   

 
 
 
 
 
 

 
 
 
 
 
 
 
3. Pada palet Optimize, pilihlah format GIF dan Colors : 64. Lihat gambar : 
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4. Untuk melihat optimasi, coba lakukan seleksi pada slice 01, ukurannya file nya menjadi 
2,066 kb. Lihat gambar : 

 
 
 
 
 
 
 
 
 
 
5. Lakukan hal yang sama untuk mengoptimasi slice atau potongan grafik berikutnya 
sampai ke potongan grafik yang terakhir.  

 
Menyimpan Desain Header 
 
Setelah header selesai, maka saatnya untuk menyimpannya. Sebelumnya sebaiknya anda 
menyimpannya didalam sebuah folder atau buat folder baru dengan nama Design kemudian 
simpan header di dalam folder tersebut, Caranya, klik menu File > Save Optimized As, isikan 
pada File name : header, Save as type : HTML and Images (*.html), Settings : Default Settings, 
Slice : All Slice. Lihat gambar : 
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Grafik Accessories dengan Grafik Label Menu  
 
Grafik aksesoris pertama yang akan dibuat adalah label untuk menu-menu yang ada di halaman 
web nantinya, agar pengunjung mengetahui bagian-bagian dari suatu situs web dengan jelas. 
 
1. Klik menu File > New, isikan Width : 175, Height : 32 dan pilih Background Contents : 
Transparent. 

 
2. Klik menu Select > All untuk memilih seluruh area. Lihat gambar : 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
3. Kemudian klik tool Gradient, ubah warna ForeGround : F2CB0E dan Background : 
EF9801, lalu klik dan seret dari atas ke bawah. Lihat gambar : 

 
 
 
 
 
 
 
 
 
4. Klik menu Edit > Stroke, isikan pada Width : 1 px, Color : 000000 dan Location : Inside. 
Lihat gambar : 
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5. Klik menu Select > Deselect, lalu klik tool Text, aturlah jenis huruf : Tahoma dengan 
ukuran : 12 pt dan berwarna hitam, lalu tulislah teks “MENU KATEGORI”. Lihat gambar : 

 
 
 
 
 
 
 
 

 
6. Kemudian simpanlah grafik label menu kategori, klik menu File > Save for Web, maka 
akan tampil kotak dialognya, pilih pada bagian Colors : 64, kemudian tekan tombol Save 
untuk menyimpan file. Lihat gambar : 
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7. Buatlah lagi label-label berikutnya sebanyak tiga buah, jadi nantinya ada empat label 
seperti gambar berikut : 

 
 
 

 
 
Catatan : 
Simpanlah label-label menu tersebut di direktori D:\Design\images dengan nama file 
menukategori.gif, menulogin.gif, menucari.gif dan menuartikel.gif 
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Grafik Label Selamat Datang 
 
Label berikutnya yang akan kita buat adalah label selamat datang sebagai ucapan selamat 
datang kepada pengunjung situs. 
 
1. Klik menu File > New, isikan Width : 425, Height : 30 dan pilih Contents : Transparent. 
 
2. Klik menu Select > All, kemudian klik tool Gradient, ubah warna Foreground : 6195BC 
dan Background : 2E5A7D, lalu klik dan seret dari atas ke bawah. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
 
3. Klik tool Text, lalu tulislah teks : SELAMAT DATANG DI WEBSITE KIOS VIDEO EZZY. 
huruf : Tahoma, ukuran : 12 pt dan warna : putih. Lihat gambar : 

 
 
 
 
 
 
 
 
 
 
4. Klik menu File > Save for Web, lalu simpanlah filenya dengan nama : selamat.gif dan 
letakkan di direktori D:\design\images. 
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Garis Pembatas Link 
 
Garis pembatas ini nantinya akan dipakai sebagai pembatas link atau menu dalammenu 
kategori dan menu artikel sebelumnya. 
 
1. Klik menu File > New, isikan Width : 175, Height : 2 dan pilih Background Contents : 
White. 

 
2. Klik tool Line, ubah warna Foreground : 000000, lalu gambarlah garis hitam secara 
horizontal seperti gambar berikut : 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
3. Klik menu File > Save for Web, lalu simpanlah filenya dengan nama garis.gif dan 
letakkan di direktori D:\design\images 
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Tombol Login dan Tombol Cari 
 
1. Klik menu File > New, isikan Width : 68, Height : 18 dan pilih Background Contents : 
Transparent 

 
2. Klik menu Select > All. Klik tool Gradient, ubah warna Foreground : 6195BC dan 
Background : 2E5A7D, lalu klik dan seret dari atas ke bawah. 

 
3. Klik menu Layer > Layer Style > Bevel and Emboss, biarkan nilainya default, lalu klik 
tombol OK. 

 
4. Klik tool Text, huruf : Tahoma, ukuran : 12 pt, warna putih, lalu tulislah teks : LOGIN. 
Lihat gambar : 

 
 
 
 
5. Klik menu File > Save for Web, lalu simpanlah filenya dengan nama : tombollogin.gif 
dan tombolcari.gif lalu letakkan di direktori D:\design\images 
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Mengorganisasikan File Web di Situs Lokal 

 

Situs lokal merupakan suatu tempat dalam harddisk yang berfungsi untuk menampung atau 

menyimpan file-file halaman web dalam bentuk root folder (folder utama) dan subfolder 

(bagian dari root folder). Artinya Anda akan menyimpan file-file web yang akan Anda buat. 

Berikut langkah-langkahnya : 

 

1. Buka program Dreamweaver, lalu klik menu Site > New Site, maka akan tampil kotak 
dialog Site Definition.  

2. Klik tab Advanced, lalu isikan pada bagian Site Name : Situs Rental Film, Local root 
folder : C:\xampp\htdocs\rental\, Default images folder : kosongkan saja, HTTP Address 

: http://www.rentalfilm.com/ (bergantung pada alamat URL Anda, jika belum tahu 

kosongkan saja), kemudian klik tombol OK. 
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Mempersiapkan Halaman Web 

 

Pertama-tama kita mempersiapkan halaman yang akan menampung semua desain dan 

pemrograman dan disinilah kita menentukan jenis halaman web yang akan kita buat, apakah 

web dinamis atau web statis. Jika halaman web yang akan kita buat berisi berita maka 

sebaiknya halaman webnya bersifat dinamis (Dynamic Pages). 

 

1. Buatlah file baru, klik menu File > New, pilihlah pada Category : Dynamic Pages 

dan bagian Dynamic Page : PHP dan klik tombol Create. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

2. Akan tampil halaman baru, kemudian klik menu Modify > Page Properties, maka 
akan tampil kotak dialognya. Pada Category : Title/Encoding, Isikan pada Title : 

Film Collection Company, dan Category : Appearance, isikan Left Margin : 0, 

Top Margin : 0, Margin Width : 0 dan Margin Height : 0. Klik tombol OK. 
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3. Klik menu File > Save As, maka akan tampil kotak dialognya, pilih pada Save in : 
C:\xampp\htdocs\rental dan isikan pada file name : index.php. 
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Membuat Tabel Induk 

 

Dalam desain ini, kita menggunakan tabel sebagai pengatur layout dari halaman web, karena 

tabel dapat mengatur tata letak desain dan program dengan cepat dan mudah. Biasanya dalam 

suatu desain dapat terdiri dari beberapa tabel. Berikut langkah-langkahnya : 

 

1. Klik menu Insert > Table, maka akan tampil kotak dialognya, isikan pada Rows : 1, 
Columns : 1, Width : 775 Pixels dan Border : 0. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

2. Kemudian lihat pada propertiesnya, pilih pada Align : Center dan isikan pada H : 
900. 
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3. Klik dalam tabel untuk memilih sel dari tabel (cell), lalu atur lagi propertiesnya, pilih 
pada bagian Vert : Top. 

 

 

 

 

 

 

 

 

Bagian Header 

 

Pada bagian header, kita akan memasang desain header yang telah kita buat di tahap desain 

web. Berikut langkah-langkahnya : 

 

1. Buka file header.html, klik menu File > Open, lalu cari di Folder 

C:\xampp\htdocs\desain\header.html, maka filenya akan terbuka.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

2. Klik dalam desain header, lalu klik menu Modify > Table > Select Table atau klik 
pada tabel, maka seluruh desain header akan terpilih. 

 

3. Kemudian klik menu Edit > Copy, lalu tutup file header.html untuk kembali ke file 
index.php, lalu klik menu Edit > Paste. 
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Menu Bagian Kiri 

 

1. Pada toolbar insert, klik tab Layout, lalu klik tombol Layout View atau combo 
Layout. 

 

 

 

 

 

 

 

2. Akan tampil kotak dialog Getting Start in Layout View, klik tombol OK, maka tab 
layout sudah berubah, di dalamnya terdapat dua tombol, yaitu Draw Layout Table 

(untuk membuat tabel) dan Draw Layout Cell (untuk membuat sel di dalam tabel). 

 

 

 

 

3. Klik tombol Draw Layout Table, lalu gambarlah tabel pada bagian kiri halaman di bawah 
header.  
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4. Agar tabel yang kita buat tepat ukurannya, kita bisa mengaturnya. Pilih Layout Table 
yang baru kita buat, lalu pilih Properties, isikan pada Width: 175 dan Height : 600. 

 

 

 

 

 

 

Menambahkan Label Menu Kategori 

 

1. Klik tombol Draw Layout Cell, lalu gambarlah sel di dalam Layout Table menu bagian 
kiri, adapun ukurannya : 175x32 (ukuran ini sesuai dengan ukuran yang dibuat saat 

mendesain web). 
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2. Klik dalam cell, lalu klik menu Insert > Image, maka akan tampil kotak dialognya. 

Carilah gambar dengan nama file kategori.gif di folder 

C:\xampp\htdocs\rental\images, lalu klik tombol OK, akan tampil gambar label 

menu kategori. 

 

 

 

 

 

 

 

 

 

 

 

 

 

Memasang Script Counter 

 

1. Klik tombol Draw Layout Cell, lalu gambar dibawah MENU KATEGORI. 
 

2. Pilih Sel yang baru kita buat, lalu lihat propertiesnya, isikan pada Width : 175, Height : 
568 dan Bg : #8D9BA6.  

 

 

 

 

3. Tekan tombol Enter di Keyboard dua kali, lalu atur di Properties Teks seperti berikut : 
 

 

 

 

 

4. Tulislah teks : “Anda adalah pengunjung ke :”, seperti terlihat pada gambar di bawah 
ini: 
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5. Buatlah file baru, klik menu File > New, pilihlah pada Category : Dynamic Pages 

dan bagian Dynamic Page : PHP dan klik tombol Create. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

6. Klik pada pilihan coding program , hapus semua baris program yang ada 

kemudian ketik program berikut : 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

7. Simpan dengan nama counter.php 
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8. Buka program notepad++, pilih menu File > New (Ctrl+N) lalu tuliskan 0 di file 
tersebut simpan dengan nama counter.txt  

 

 

 

 

 

 

 

 

 

 

9. Kemudian tekan tombol Shift+Enter di keyboard secara bersamaan untuk pindah 
baris, lalu klik komponen Include pada tab PHP. 

 

 

 

 

10. Akan tampil mode tampilan kode (Code), lalu ketikkan “counter.php”. 
 

 

 

 

 

11. Pilih atau klik pada mode tampilan desain (Design), akan terlihat seperti berikut : 
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Membuat Banner Dengan Swish 

 

1. Buka program Swish dengan memilih menu Start > All Programs > Swish v2.0. 

akan tampil seperti berikut : 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

2. Pilih menu File > New, lihat sebelah kanan panel/jendela Movie atur Width : 175, 

Height: 100, Bgnd Color : #8D9BA6. 

 

 

 

 

 

 

 

 

3. Pada ToolBar klik icon Teks  akan tampil pada kanvas seperti berikut : 
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4. Pada panel Teks sebelah kanan Ketikkan “The Best Video” kemudian ubah warnanya 
menjadi kuning. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

5. Pilih Menu Insert > Effect > Slide In > From Top. 
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6. Tambahkan durasi framenya dengan cara klik tahan geser effect Slide in from Top 
pada frame.  

 

 

 

 

7. Tambahkan lagi effect Slide Out To Right pada pada posisi Frame ke 45. 
 

 

 

 

8. Untuk menjalankannya klik icon Play  pada ToolBar dan untuk menghentikan proses 

klik icon Stop . 

9. Jika sudah selesai file tersebut kita export dalam bentuk .swf dengan cara pilih menu 
File > Export > SWF (Ctrl+E). Simpan pada folder C:\xampp\htdocs\rental dan 

isikan File name : banner.swf. 

 

 

 

 

 

 

 

 

 

 

 

10. Tempatkan kursor mouse di sebelah kanan script counter, lalu tekan tombol enter dua 
kali. 
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11. Kemudian klik menu Insert > Media > Flash, akan tampil kotak dialognya.Carilah banner 
dengan nama file : banner.swf di folder : C:\xampp\htdocs\rental, lalu klik tombol OK, 

akan tampil banner dengan label F. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Bagian Content/Body 

 

Bagian ini merupakan bagian yang paling luas areanya karena pada bagian inilah berita-berita 

terbaru biasanya ditampilkan.  

 

Klik tab Layout, lalu klik tombol Draw Layout Table, kemudian gambarlah tabel disebelah 

kanan menu bagian kiri, adapun ukurannya 410x600.  
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Memasang Label Selamat Datang 

 

1. Klik tombol Draw Layout Cell, lalu gambarlah sel di dalam Layout Table bagian Content, 
adapun ukurannya : 427x32. 

 

 

 

 

 

 

 

 

 

 

 

 

2. Klik dalam cell, lalu klik menu Insert > Image, maka akan tampil kotak dialognya. 

Carilah gambar dengan nama file selamat.gif di folder 

C:\xampp\htdocs\rental\images, lalu klik tombol OK, akan tampil gambar label 

Selamat. 

 

 

 

 

 

 

 

 

 

 

 

Menu Bagian Kanan 

 

1. Klik tombol Draw Layout Cell, lalu gambarlah sel di dalam Layout Table menu bagian 
kanan, adapun ukurannya : 175x32. 
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2. Klik dalam Cell, lalu klik menu Insert > Image, akan tampil kotak dialognya. Carilah 

gambar dengan nama file menulogin.gif di folder 

C:\xampp\htdocs\rental\images, lalu klik tombol OK, akan tampil gambar menu 

login. 

 

 

 

 

 

 

 

 

 

 

Bagian Footer 

 

1. Klik tab Layout, lalu klik tombol Draw Layout Cell, kemudian gambarlah sel di bagian 
paling bawah, yaitu bagian footer. Adapun ukurannya adalah 775x50. 

 

 

 

 

 

 

 

 

 

2. Klik dalam sel, klik menu Insert > HTML > Horizontal Rule untuk membuat garis 
memanjang, lalu di samping garis tuliskan teks yang akan langsung berada di bawah 

garis tersebut : “Copyright © 2009 Video Collection Company, Allright 

Reserved”, dan aturlah teks dengan rata tengah. Untuk menyisipkan symbol Copyright 

© pada Dreamweaver, klik menu Insert > HTML > Special Characters > 

CopyRight. 

 

 

 

 

 

 

 

 

 

 

 


